m-oauth/package.json

55 lines
1.5 KiB
JSON

{
"name": "m-oauth",
"version": "0.0.1",
"private": true,
"author": "SevicheCC",
"scripts": {
"dev": "next dev --turbo",
"build": "NODE_ENV=production next build",
"start": "next start",
"lint": "next lint",
"lint:fix": "eslint . -fix",
"prepare": "husky install"
},
"dependencies": {
"@hookform/resolvers": "^3.1.0",
"@radix-ui/react-avatar": "^1.0.3",
"@radix-ui/react-checkbox": "^1.0.4",
"@radix-ui/react-collapsible": "^1.0.3",
"@radix-ui/react-label": "^2.0.2",
"@radix-ui/react-select": "^1.2.2",
"@radix-ui/react-slot": "^1.0.2",
"@radix-ui/react-toast": "^1.1.4",
"class-variance-authority": "^0.6.0",
"clsx": "^1.2.1",
"lucide-react": "^0.240.0",
"next": "13.4.4",
"next-themes": "^0.2.1",
"react": "18.2.0",
"react-dom": "18.2.0",
"react-hook-form": "^7.44.3",
"tailwind-merge": "^1.13.0",
"tailwindcss-animate": "^1.0.5",
"zod": "^3.21.4"
},
"devDependencies": {
"eslint": "8.41.0",
"eslint-config-prettier": "^8.8.0",
"husky": "^8.0.3",
"lint-staged": "^13.2.2",
"prettier": "^2.8.8",
"prettier-plugin-tailwindcss": "^0.3.0",
"tailwindcss": "^3.3.2",
"@types/node": "20.2.5",
"@types/react": "18.2.7",
"@types/react-dom": "18.2.4",
"eslint-config-next": "13.4.4",
"autoprefixer": "^10.4.14",
"postcss": "^8.4.24",
"typescript": "5.0.4"
},
"lint-staged": {
"*.js": "eslint --cache --fix",
"*.{js,css,md}": "prettier --write"
}
}